Page 8 of 10

Re: Howto update to 01.01

Posted: Tue Aug 25, 2015 12:39 pm
by CloneNum3
elalqui wrote:I updated my winkhub for 0.1 to 1.1 following your steps. Root is still working and I can ssh the device;but the winkhub resets every ~3 minutes.
It seems that there is process running in the background that times out and triggers the reboot.
Please, do you know how to solve this issue?


During the 3 minutes, can you run "ps" and see if there are any processes that stick out?

Re: Howto update to 01.01

Posted: Thu Sep 17, 2015 2:04 pm
by GhostHost
I just tried this same procedure for an upgrade from 01.01 to 02.19 as well and it still works fine.

Re: Howto update to 01.01

Posted: Sun Sep 20, 2015 2:31 am
by elalqui

Code: Select all

/usr/bin/monit -Ic /etc/monitrc

The monit script is resetting the hub because aprond and ZigbeeHACoord are not running.

Code: Select all

root@flex-dvt ~]#/usr/sbin/aprond
i: [1601.1] main() (Main|apron.c:63): APRON Home Automation Gateway version 1.2.0+localhost.localdomain-git{7427ea3}-20150911.143038 Starting ...
connect() failed: No such file or directory

root@flex-dvt ~]#ZigBeeHACoord -n 1 -p ttySP4 -Q -I /database/zigbee-ota-image
s
Reset info: 11 (SOFTWARE)
# ERROR: ezspForceReset 0x21
ZigBeeHACoord: app/framework/util/af-main-host.c:347: emAfResetAndInitNCP: Assertion `0' failed.


Any idea about how to solve the issue?

Re: Howto update to 01.01

Posted: Sun Sep 20, 2015 7:29 am
by lordpengwin
Has anyone updated to the latest firmware, not sure the new version number, but it came out the week of Sept 15. Does the process on this thread still work?

Re: Howto update to 01.01

Posted: Sun Sep 20, 2015 8:47 am
by OuTTaRiCe
elalqui wrote:

Code: Select all

/usr/bin/monit -Ic /etc/monitrc

The monit script is resetting the hub because aprond and ZigbeeHACoord are not running.

Code: Select all

root@flex-dvt ~]#/usr/sbin/aprond
i: [1601.1] main() (Main|apron.c:63): APRON Home Automation Gateway version 1.2.0+localhost.localdomain-git{7427ea3}-20150911.143038 Starting ...
connect() failed: No such file or directory

root@flex-dvt ~]#ZigBeeHACoord -n 1 -p ttySP4 -Q -I /database/zigbee-ota-image
s
Reset info: 11 (SOFTWARE)
# ERROR: ezspForceReset 0x21
ZigBeeHACoord: app/framework/util/af-main-host.c:347: emAfResetAndInitNCP: Assertion `0' failed.


Any idea about how to solve the issue?


Have you checked that all your filesystems were mounted properly?
I have a feeling your /database filesystem isn't mounted.

Re: Howto update to 01.01

Posted: Sun Sep 20, 2015 8:28 pm
by elalqui
The mtd3 partition is mounted.

Code: Select all

[root@flex-dvt ~]# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00300000 00020000 "gpmi-nfc-0-boot"
mtd1: 00400000 00020000 "updater-kernel"
mtd2: 01c00000 00020000 "updater-rootfs"
mtd3: 00800000 00020000 "database"
mtd4: 00800000 00020000 "app-kernel"
mtd5: 04d00000 00020000 "gpmi-nfc-general-use"

Re: Howto update to 01.01

Posted: Tue Sep 22, 2015 7:48 am
by lordpengwin
Hi, I just want to report that I did an update to the latest firmware last night and all seems to have gone well. It is now reporting version 2.19.0.
Does anyone know what new functionality it has?

Re: Howto update to 01.01

Posted: Wed Sep 23, 2015 11:53 pm
by noily
Hi,
I have a rooted hub with the original FW 0.01. I can login to it via SSH and I can see the log on the serial via ftdi cable. So I have these questions:
1) How do I add the Wink hub in the phone app now that it is not acting as an access point. My mistake I did not install the app(and add the hub) before the rooting part...not following directions :)

2) Could I use the same steps on this thread to update to the latest FW? Looking at this site(http://wink-hub-images.s3.amazonaws.com ... _00.01.txt), it looks like the FW is now 02.19. Is this right? Has anybody tried this yet?

Thanks.

Re: Howto update to 01.01

Posted: Sun Oct 04, 2015 6:33 pm
by dubbedout
Has anyone successfully updated and maintained root with the newest 2.19 firmware? It was released mid September.

Re: Howto update to 01.01

Posted: Sun Feb 07, 2016 10:41 am
by lordpengwin
I'm trying to do the upgrade from 2.19 to 2.49 and when I run /root/platform/upgrade.sh in step 4 i get the error message "URL or certificate information missing, update canceled."

It looks like i'm missing /database/cf_url and /database/cf_cert. Does anyone know where I can get these? Also any idea why i don't have them?