Howto update to 01.01

blink
Posts: 2
Joined: Sun May 03, 2015 12:57 pm

Re: Howto update to 00.86

Postby blink » Sun May 03, 2015 2:02 pm

I'm caught in ugprade hell.

Before I realized the the DNS bug was present, I followed the upgrade instructions. At some stage, I lost track of where we are in the upgrade process. Now I'm trying to restore things to a known state, but I'm not sure how.

I followed the Factory Reset Preserving Root directions, but as we speak, I'm getting the pink flashing light and I have 4 WINKHUB-NNNXXX-XXXX networks showing up.

I assume each of these networks is due to flash file systems being mounted and they are somehow fighting over the WiFi AP control? It seems there should be a straightforward way of deleting bad updates, unmount the right file systems, mounting other file systems, and fundamentally booting back to a known state.

Obviously, I don't understand how the boot process and upgrade process work. Any thoughts on how to resolve this?

lordpengwin
Posts: 8
Joined: Wed May 13, 2015 3:09 pm

Re: Howto update to 00.89

Postby lordpengwin » Wed May 13, 2015 3:11 pm

I followed this procedure on a 00.33 hub and am now at 00.86. Do I have to do it again to get to 00.89?

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.89

Postby CloneNum3 » Wed May 13, 2015 8:28 pm

lordpengwin wrote:I followed this procedure on a 00.33 hub and am now at 00.86. Do I have to do it again to get to 00.89?


That is an excellent question... My initial instinct was to say yes... but, I thought it through and there is really no reason you need to, as long as...

[*] /database/authorized_keys # contains public SSH keys which you have the matching private key for (if you are currently able to ssh in without typing a password, you are probably set here...)

[*] /database/ENABLE_SSH exists

Just to be sure, I tested it on a 00.86 hub of mine just now... worked like a charm, I can still SSH in without doing anything special.

FYI, I did have to SSH in and initiate the update because I had already deleted the S99 file which would normally have started the update. I also had to reboot because I had already commented out the reboot commands in the scripts... but if S99 had still existed and reboot was never commented out, it should have worked just fine.

bigmonkey70
Posts: 4
Joined: Tue Apr 21, 2015 8:01 am

Re: Howto update to 00.89

Postby bigmonkey70 » Fri May 15, 2015 9:52 am

From the latest firmware check link http://wink-hub-images.s3.amazonaws.com ... _00.01.txt still show 00.86 is the latest.
Is 00.89 only for hub that need to be recover from the last upgrade problem? I tried to upgrade but firmware stay at 00.86. I also did the reset to factory and keep root instruction and then follow step 6 and at the end firmware still 00.86

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.89

Postby CloneNum3 » Sun May 17, 2015 9:30 am

bigmonkey70 wrote:From the latest firmware check link http://wink-hub-images.s3.amazonaws.com ... _00.01.txt still show 00.86 is the latest.
Is 00.89 only for hub that need to be recover from the last upgrade problem? I tried to upgrade but firmware stay at 00.86. I also did the reset to factory and keep root instruction and then follow step 6 and at the end firmware still 00.86


I'm finding 00.86 to be the latest currently available update. The 00.89 was either a typo or was retracted.

I searched through all the update servers I could find and verified 00.86 was in fact the only version currently available. Here are the servers I checked.

Code: Select all

54.231.0.241
54.231.10.97
54.231.112.48
54.231.11.96
54.231.11.96
54.231.12.225
54.231.12.225
54.231.13.153
54.231.13.225
54.231.13.225
54.231.14.17
54.231.14.17
54.231.15.25
54.231.15.41
54.231.16.121
54.231.17.105
54.231.18.161
54.231.18.177
54.231.18.241
54.231.18.241
54.231.18.57
54.231.2.193
54.231.32.161
54.231.32.161
54.231.33.89
54.231.48.104
54.231.48.104
54.231.48.40
54.231.64.17
54.231.64.17
54.231.64.193
54.231.64.25
54.231.65.81
54.231.80.88
54.231.80.88
54.231.8.17
54.231.8.177
54.231.9.1
54.231.9.17
54.231.9.17


All responded with:

Code: Select all

board_id=00.01
group_id=0
sw_pkg_url=https://wink-hub-images.s3.amazonaws.com/00.01
fparts=4
alt_pkg_url=https://hub-updates.winkapp.com/00.01
fdest0=/dev/mtd1
fver0=00.01
foff0=0
ftype0=0
fsrc0=updater-uImage
md5sum0=11b29593183c2b94a85b333c03a3b52c
fdest1=/dev/mtd2
fver1=00.08
foff1=0
ftype1=1
fsrc1=updater-rootfs.ubi
md5sum1=a8adc80bc20f6066d06fc533fb15502f
fdest2=/dev/mtd4
fver2=00.01
foff2=0
ftype2=0
fsrc2=app-uImage
md5sum2=11b29593183c2b94a85b333c03a3b52c
fdest3=/dev/mtd5
fver3=00.86
foff3=0
ftype3=1
fsrc3=app-rootfs.ubi
md5sum3=406767485b206620203dcaba05c6f6fa

mothpaul
Posts: 5
Joined: Sat Jan 10, 2015 2:38 pm

Re: Howto update to 00.89

Postby mothpaul » Mon May 25, 2015 10:00 am

Thanks CloneNum3.

I was able to update but found it necessary to use the "echo 1 > /database/DO_UPDATE" trick to force reboot to mtd2 at the end of step 5. Otherwise it worked great.

BTW - to ssh into the hub, I also had to update my known_hosts files on OS X between booting to mtd2 and mtd5. I don't know how this works with other machines.

Thanks again.

lims01
Posts: 1
Joined: Fri Jun 26, 2015 8:17 pm

Re: Howto update to 00.89

Postby lims01 » Fri Jun 26, 2015 8:25 pm

I was hoping someone could help me out here, I have a GE link bulb connected to Wink Hub that was rooted right out of the box, no idea of its firmware (is there an aprontest command to check this?) I do see the Wink hub under Vera and its statues shows Ready for either local or combined however i do not see the devices appear (i can turn the bulb on and off with aprontest commands.) I tried to follow the upgrade instructions as I am concerned the firmware is too early, I then however see the below error, any ideas here?

login as: root
root@192.168.2.78's password:
[root@flex-dvt ~]# touch /database/ENABLE_SSH
[root@flex-dvt ~]# cp /root/.ssh/authorized_keys /database/authorized_keys
[root@flex-dvt ~]# sed -i 's/reboot/#reboot/g' /root/platform/*.sh
[root@flex-dvt ~]# cp /var/www/set_dev_value.php /database/set_dev_value.php # S
ave for later
[root@flex-dvt ~]# /root/platform/upgrade.sh
Press enter to cancel update...
cat: can't open '/database/cf_url': No such file or directory
cat: can't open '/database/cf_fver0': No such file or directory
No valid version for part 0, set to 00.00
cat: can't open '/database/cf_fver1': No such file or directory
No valid version for part 1, set to 00.00
cat: can't open '/database/cf_fver2': No such file or directory
No valid version for part 2, set to 00.00
cat: can't open '/database/cf_fver3': No such file or directory
No valid version for part 3, set to 00.00
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (7) Failed to connect to hub-updates.winkapp.com port 443: Connection refused
Could not open https://hub-updates.winkapp.com/00.01
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (7) Failed to connect to wink-hub-images.s3.amazonaws.com port 443: Connection refused
Could not open https://wink-hub-images.s3.amazonaws.com/00.01.
END
[root@flex-dvt ~]#

ptmuldoon
Posts: 14
Joined: Thu Mar 19, 2015 8:54 pm

Re: Howto update to 00.89

Postby ptmuldoon » Tue Jun 30, 2015 2:58 pm

Check what your /etc/hosts file shows.

it may be blocking the connection to the hub images.

I just updated my rooted hub, and it appears that latest version is now 1.1. But the instructions still work just fine.

elalqui
Posts: 7
Joined: Sun Jul 19, 2015 12:45 am

Re: Howto update to 01.01

Postby elalqui » Sun Jul 19, 2015 12:51 am

I updated the winkhub for 0.1 to 1.1. Root is still working and I can ssh to the device; but the winkhub is rebooting every ~3 minutes.
It seems that there is a process running in the background that times out after ~3 minutes.
Please, do you know how to resolve this issue?

elalqui
Posts: 7
Joined: Sun Jul 19, 2015 12:45 am

Re: Howto update to 01.01

Postby elalqui » Sun Jul 19, 2015 1:01 am

I updated my winkhub for 0.1 to 1.1 following your steps. Root is still working and I can ssh the device;but the winkhub resets every ~3 minutes.
It seems that there is process running in the background that times out and triggers the reboot.
Please, do you know how to solve this issue?


Return to “Upgrade to current firmware maintaining root”

Who is online

Users browsing this forum: No registered users and 1 guest