Howto update to 01.01

JohnM
Posts: 9
Joined: Wed Apr 22, 2015 1:23 am

Re: Howto update to 00.86 - error step 4

Postby JohnM » Thu Apr 23, 2015 10:29 am

Sorry I copied the wrong parts, understand that these are the outputs. The problem is when running /root/platform/upgrade.sh not update is generated like the last time, line just defaults to prompt.

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.86 - error step 4

Postby CloneNum3 » Thu Apr 23, 2015 10:31 am

JohnM wrote:Sorry I copied the wrong parts, understand that these are the outputs. The problem is when running /root/platform/upgrade.sh not update is generated like the last time, line just defaults to prompt.


I suspect something happened to your wink device outside of the norm... example, you should never have to run chmod +x on the update scripts as they should never be lost...

I'll PM you.

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.86 - error step 4

Postby CloneNum3 » Thu Apr 23, 2015 11:36 am

CloneNum3 wrote:
JohnM wrote:Sorry I copied the wrong parts, understand that these are the outputs. The problem is when running /root/platform/upgrade.sh not update is generated like the last time, line just defaults to prompt.


I suspect something happened to your wink device outside of the norm... example, you should never have to run chmod +x on the update scripts as they should never be lost...

I'll PM you.


what happens when you...

Code: Select all

cat /root/platform/upgrade.sh


or

Code: Select all

ls -al /root/platform/

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.86

Postby CloneNum3 » Thu Apr 23, 2015 11:38 am

Actually, I have an idea that should get you going...

Try these instructions...
http://www.rootwink.com/viewtopic.php?f=13&t=64

JohnM
Posts: 9
Joined: Wed Apr 22, 2015 1:23 am

Re: Howto update to 00.86

Postby JohnM » Thu Apr 23, 2015 2:07 pm

CloneNum3 wrote:Actually, I have an idea that should get you going...

Try these instructions...
http://www.rootwink.com/viewtopic.php?f=13&t=64


Hiya,
I tried the instructions and it got my system going again, was able to return to step 6# to run /root/platform/upgrade.sh which this time spewed out content similar to yours but had issues with the datecheck at the end.

Example of the last part of it,
+ datecheck='Thu Jan 1 00:23:16 UTC 1970'
+ '[' '' '!=' 'Thu Jan 1 00:23:16 UTC 1970' ']'
+ ntpdate 0.rhel.pool.ntp.org 1.rhel.pool.ntp.org
Exiting, name server cannot be used: Temporary failure in name resolution (-3) 1 Jan 00:23:16 ntpdate[3822]: name server cannot be used: Temporary failure in name resolution (-3)
+ '[' 0 = 1 ']'
+ (( idx++ ))
+ (( idx<3 ))
+ return 1
+ '[' 0 '!=' 1 ']'
+ echo 'unable to set date.'
unable to set date.
+ set_boot_application
+ flash_set DO_UPDATE 0
+ echo 0
+ end 1
+ echo END


I'll check the DNS settings as suggested, if I need to make changes from which step should I run again?

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.86

Postby CloneNum3 » Thu Apr 23, 2015 3:20 pm

JohnM wrote:I'll check the DNS settings as suggested, if I need to make changes from which step should I run again?


From what I can tell, all it failed to do was set the time... your hub probably thinks it's January 1st 1970.

Here is an example of me manually setting the date "date -s" to 1/1/1970... displaying the date... updating the date directly from 208.88.126.226 (one of the addresses 0.rhel.pool.ntp.org points to)... and displaying the date again showing a current and correct date and time.

Try running ntpdate with an IP address instead of a domain name.

Code: Select all

[root@flex-dvt ~]# date -s 197001010000
Thu Jan  1 00:00:00 UTC 1970
[root@flex-dvt ~]# date
Thu Jan  1 00:00:06 UTC 1970
[root@flex-dvt ~]# ntpdate 208.88.126.226
23 Apr 19:18:27 ntpdate[1272]: step time server 208.88.126.226 offset 1429816688.531553 sec
[root@flex-dvt ~]# date
Thu Apr 23 19:18:30 UTC 2015
[root@flex-dvt ~]# 

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.86

Postby CloneNum3 » Thu Apr 23, 2015 3:21 pm

CloneNum3 wrote:
JohnM wrote:I'll check the DNS settings as suggested, if I need to make changes from which step should I run again?


From what I can tell, all it failed to do was set the time... your hub probably thinks it's January 1st 1970.

Here is an example of me manually setting the date "date -s" to 1/1/1970... displaying the date... updating the date directly from 208.88.126.226 (one of the addresses 0.rhel.pool.ntp.org points to)... and displaying the date again showing a current and correct date and time.

Since I'm using an IP address instead of a DNS name, DNS isn't required

Try running ntpdate with an IP address instead of a domain name.

Code: Select all

[root@flex-dvt ~]# date -s 197001010000
Thu Jan  1 00:00:00 UTC 1970
[root@flex-dvt ~]# date
Thu Jan  1 00:00:06 UTC 1970
[root@flex-dvt ~]# ntpdate 208.88.126.226
23 Apr 19:18:27 ntpdate[1272]: step time server 208.88.126.226 offset 1429816688.531553 sec
[root@flex-dvt ~]# date
Thu Apr 23 19:18:30 UTC 2015
[root@flex-dvt ~]# 

CloneNum3
Site Admin
Posts: 107
Joined: Wed Jan 07, 2015 10:02 am

Re: Howto update to 00.86

Postby CloneNum3 » Thu Apr 23, 2015 3:22 pm

CloneNum3 wrote:
CloneNum3 wrote:
JohnM wrote:I'll check the DNS settings as suggested, if I need to make changes from which step should I run again?


From what I can tell, all it failed to do was set the time... your hub probably thinks it's January 1st 1970.

Here is an example of me manually setting the date "date -s" to 1/1/1970... displaying the date... updating the date directly from 208.88.126.226 (one of the addresses 0.rhel.pool.ntp.org points to)... and displaying the date again showing a current and correct date and time.

Since I'm using an IP address instead of a DNS name, DNS isn't required

Try running ntpdate with an IP address instead of a domain name.

Code: Select all

[root@flex-dvt ~]# date -s 197001010000
Thu Jan  1 00:00:00 UTC 1970
[root@flex-dvt ~]# date
Thu Jan  1 00:00:06 UTC 1970
[root@flex-dvt ~]# ntpdate 208.88.126.226
23 Apr 19:18:27 ntpdate[1272]: step time server 208.88.126.226 offset 1429816688.531553 sec
[root@flex-dvt ~]# date
Thu Apr 23 19:18:30 UTC 2015
[root@flex-dvt ~]# 

JohnM
Posts: 9
Joined: Wed Apr 22, 2015 1:23 am

Re: Howto update to 00.86

Postby JohnM » Thu Apr 23, 2015 3:53 pm

Thank you, I will try that. I have blue light back on my wink hub, since the update, without the date being corrected will do that next. Just wanted to update you to say that the hub is now fully working again and blue solid light.

:D :D :D :D :D

blink
Posts: 2
Joined: Sun May 03, 2015 12:57 pm

Re: Howto update to 00.86

Postby blink » Sun May 03, 2015 1:45 pm

Is there a way to reset the hub back to an initial state? I'm caught in some sort of upgrade loop hell and I'd like to just reset the state by removing upgrades...


Return to “Upgrade to current firmware maintaining root”

Who is online

Users browsing this forum: No registered users and 1 guest