Wireless won't connect. Keeps throwing errors

Are you stuck at a particular point, can't find the answer elsewhere, here's the place to ask.
genesisfactor
Posts: 6
Joined: Thu Jul 23, 2015 10:16 am

Wireless won't connect. Keeps throwing errors

Postby genesisfactor » Thu Jul 23, 2015 10:53 am

Hey everyone!

So my winkhub was rooted and connecting to my wireless at one time.

TL;DR:
I am getting this error repeating whenever i try to connect to an AP, when it finally turns blue. Gets here using the app and the curl command.

Code: Select all

dhd_aoe_hostip_clr failed code -23
ace_update_host_ipv4_table_failed

not sure what to do. ran the upgrade.

Before all of this, it connected to wifi when rooted and connected to serial. Wouldn't get past the green light otherwise.

I got the time:
I did something stupid when it wouldn't boot past the green light unless connected to serial and after reading some forums, did

Code: Select all

setenv bootdelay 2
saveenv
which was fine, except i did it in the main...and then somehow it got updated from the wink app (i have two of them and was trying to update one).

I updated it using the tutorial on this forum, and now it is responsive, but it is also not connecting and i get those errors. I tired deleting /database/wpa_supplicant.config. The file it calls never gets created, I can ssh using the wink's ssid and get the appropriate response, but that SSID sometimes fails to show up, and makes it hard to use as the local bridge. i don't know why or what is preventing it (my google-fu has failed me). tried the

Code: Select all

curl "http://192.168.0.1/index.php" -d '{"ssid":"----","pass":"----"}'
and it just claims the wireless event is too big. The second, unrooted wink hub has no such problems with connectivity, ruling out my wifi.

Other things to note: i ended /etc/hosts and hostname and gave myself a custom hostname, although this wasn't a problem before.

Please help :( I just wanna get openhab going

genesisfactor
Posts: 6
Joined: Thu Jul 23, 2015 10:16 am

Re: Wireless won't connect. Keeps throwing errors

Postby genesisfactor » Sun Jul 26, 2015 2:50 am

Fixed it by
1. downloading the app-rootfs.ubi file from the wink servers
2. creating a nodejs server on my laptop and putting the file in there
3. joining my laptop with the wink hub AP (it as in ap mode)
4. changed a couple files on the wink hub and then did a wget on the file on the wink hub to dl the update (it wouldn't connect to the net)
5. running a mix of the update procedures google-able both here and elsewhere online for manual updates.
6. connected via the app (wouldn't work using curl)

may do a write up later. was pretty interesting to figure out.

froglegs
Posts: 1
Joined: Mon Oct 26, 2015 3:45 pm

Re: Wireless won't connect. Keeps throwing errors

Postby froglegs » Mon Oct 26, 2015 3:57 pm

I tried to pm you this request but my account is to new. Anyway, if you have time could you add a little more detail to your fix? I have a hub completely updated to 2.19 but it stays at a solid yellow after boot up. When connecting via UART I'm seeing the same errors you were getting. I know its getting on the network because I can ping outside hosts from the device but it never links up via the app. I followed step one and have the file but I'm a bit lost after that. Thanks in advance.

Jonesie
Posts: 23
Joined: Sat Feb 14, 2015 11:22 am

Re: Wireless won't connect. Keeps throwing errors

Postby Jonesie » Mon Nov 09, 2015 3:33 pm

froglegs wrote:I tried to pm you this request but my account is to new. Anyway, if you have time could you add a little more detail to your fix? I have a hub completely updated to 2.19 but it stays at a solid yellow after boot up. When connecting via UART I'm seeing the same errors you were getting. I know its getting on the network because I can ping outside hosts from the device but it never links up via the app. I followed step one and have the file but I'm a bit lost after that. Thanks in advance.


I have the same issue. Any luck?

Additionally, sometime in the middle of the night all of my GE Link Bulbs come on full brightness. I have to do the "If your lights aren't working" steps on the link below to reconnect my lights.

http://hubfix.wink.com/connect.html

Jonesie

genesisfactor
Posts: 6
Joined: Thu Jul 23, 2015 10:16 am

Re: Wireless won't connect. Keeps throwing errors

Postby genesisfactor » Sun Jul 03, 2016 6:19 pm

Hey! sorry, i didn't see this post...

The node.js server is really *any* webserver you can host locally on a machine that can connect to the wink when the wink is in access pointmode. in the end, you just want to act as the amazon server wink hosts their updates on.

i still get issues, but they were far less than before. My final solution is to attach a raspberry pi to it over serial which reads the event error code and tries to reboot the wink or restart the wifi. Actually, seeing how to having it restart the wifi without a reboot is why i'm came back!

Also, i think the issue stems from my router. i've had other devices drop on my 2.4ghz. The wink just seems to be the one showing off the most issues. Oh AC routers...why do your 2.4ghz suck so hard?

If you need any further help, let me know. i can send you the code, but...its really nothing you can't put together in a few minutes

genesisfactor
Posts: 6
Joined: Thu Jul 23, 2015 10:16 am

Re: Wireless won't connect. Keeps throwing errors

Postby genesisfactor » Sun Jul 03, 2016 6:27 pm

ok, for the record, you can use this to restart your wireless without rebooting your hub,if you have a serial device attached to it. Woohoo!

Code: Select all

/etc/init.d/S41wireless restart


Return to “Help me, I can't do xyz”

Who is online

Users browsing this forum: No registered users and 4 guests